Partial Power Outage: CHI-1 Thursday 14th May 2020 07:30:00


7:30 AM CT: There is a partial power outage at our CHI1 data center. The facility operations team is working to resolve this currently.

The problematic UPS system is now fully operational, and testing and monitoring show all functions are now normalized.

Due to the inclement weather around the CHI-1 facility and more lightning storms on the way, we are switching the faulty UPS side to generator backup rather than relying on utility power. The corresponding utility provider has reported numerous issues and has been dropping repeatedly. The UPS still remains on bypass until the UPS technicians confirm it is ready for operational use again. By switching to generators now, we can move to UPS and utility without losing power to the floor again.

UPDATE: 9:37AM CT: Systems have been coming back online and have remained stable. Customers should also have seen devices come back online.

UPDATE: 8:07 AM CT: The facilities team has restored power to the degraded side and servers are coming back online. We will continue to monitor this.